What are the system requirements and dependencies of WissKI?

The WissKI system is a set of modules which extends the Content Management System Drupal Version 6 by a virtual research environment. The dependencies for Drupal 6 are documented at the Drupal website (https://www.drupal.org/requirements). Additionally, the WissKI system has as semantic backend a triplestore instead of Drupal’s database. The graphical text editor is a modular extension of the HTML editor TinyMCE.

To put it in a nutshell, the WissKI system has got the following dependencies:

  • Drupal version 6
  • Any XAMPP package with the following features or a manual installation of:
    • PHP 5.2/5.3
    • MySQL 4.1 or higher respectively alternative PostgreSQL 7.1, MariaDB, MSSQL or other supported database systems
    • Apache
  • ARC2 (ARC RDF Classes for PHP) triplestore (https://github.com/semsol/arc2) and optional any SPARQL 1.1 compliant triplestore
  • TinyMCE 3